domain redirects

MyTechForum

Reputable
Oct 19, 2019
109
43
28
36
Norway
www.mytechforum.net
FP$
353
I have installed phpbb in root of my host and a wordpress site under mytechforum.net/blog and when i try to access the www.mytechforum.net (wich would be my forum) it automaticly redirects to www.mytechforum.net/blog, but if i only go to mytechforum.net whitout the "www" i get in to the forum. Anybody know why and how i can get www.mytechforum.net to go to the forum instead of my blog? Really annoying when it does like this :p
 
  • Agree
Reactions: TechWiz18

Carlos X

Addicted
Feb 28, 2013
770
243
78
California
www.carlosx360.com
FP$
2,354
In my opinion, I would have put the blog on root, and forum in /forum. But instead, what you've just done is put forum in root, and blog in /blog.

Right now, though, you need to make a decision: Where do you want MyTechForum.net to go? The blog or the forum. The reason why I say this, is because the next thing you need to do is edit your htaccess in your root. And you can't really split the redirection in two. Well, you can, but you're going to confuse the bots, so let's just keep things simple, bro.

Once you've done that, look for tutorials of how to redirect your site to your wordpress installation, or how to redirect to your phpbb installation. They are a little tricky. I say more on the wordpress part. It was very hard for me to find the absolute best way to pull all redirects into a https frontpage.

This is how my htaccess looks on the wordpress installation...

Code:
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^(.*)$ https://destroyrepeat.com/$1 [R,L]

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php72” package as the default “PHP” programming language.
<IfModule mime_module>
  AddHandler application/x-httpd-ea-php72 .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit

Don't worry about the cpanel code and/or the comodo validation stuff, they're not important to the discussion.
 
Last edited:

MyTechForum

Reputable
Oct 19, 2019
109
43
28
36
Norway
www.mytechforum.net
FP$
353
Hi, and thanks for reply. The reason i went with forum in root and blog in /blog is that i was only going to have a forum at first hence the domain "mytechforum.net" but i later on decided to have a blog aswell to add some content to get more visability in the search engines.

Not that good with the domain/redirects/htaccess so not quite sure what you did mean :p but at i'm going to have forum in root and blog in /blog if that makes it easier to help me :p
 

Carlos X

Addicted
Feb 28, 2013
770
243
78
California
www.carlosx360.com
FP$
2,354
Hi, and thanks for reply. The reason i went with forum in root and blog in /blog is that i was only going to have a forum at first hence the domain "mytechforum.net" but i later on decided to have a blog aswell to add some content to get more visability in the search engines.

Not that good with the domain/redirects/htaccess so not quite sure what you did mean :p but at i'm going to have forum in root and blog in /blog if that makes it easier to help me :p
Okay, so in that case... go on google, and search "how to redirect phpbb [version number here]." Don't forget to set up a link on your forum to the blog.
 

MyTechForum

Reputable
Oct 19, 2019
109
43
28
36
Norway
www.mytechforum.net
FP$
353
Okay, so in that case... go on google, and search "how to redirect phpbb [version number here]." Don't forget to set up a link on your forum to the blog.
I talked to my host and when they replyed they said, we can see that you allredy fixed the issue, and after that everything worked just fine, so guess i did something that resolved the issue whitout noticing it at first :p but thanks for your help :)
 

Carlos X

Addicted
Feb 28, 2013
770
243
78
California
www.carlosx360.com
FP$
2,354
I talked to my host and when they replyed they said, we can see that you allredy fixed the issue, and after that everything worked just fine, so guess i did something that resolved the issue whitout noticing it at first :p but thanks for your help :)
Oh. I see. I guess my help was useless. :( But I'm glad you got the solution.
 
  • Like
Reactions: ChrisGrigg