Guests landing on "unknown page"

I continuously have guests landing on "unknown page". Any ideas why this may be or how I can track this down and resolve it?

Image attached:
View attachment 6482
It's probably bots looking for links that are usually on another software, to exploit the software. Either that, or your previous links are gone.

Go to your [Google] search console Control Panel and start checking your links as "fixed" to stop getting those.
 
  • Like
Reactions: JoyFreak

JoyFreak

Resident
I continuously have guests landing on "unknown page". Any ideas why this may be or how I can track this down and resolve it?

Image attached:
View attachment 6482
It's probably bots looking for links that are usually on another software, to exploit the software. Either that, or your previous links are gone.

Go to your [Google] search console Control Panel and start checking your links as "fixed" to stop getting those.
Ok waiting for it to be validated!

Thank you for your help :D
 
I continuously have guests landing on "unknown page". Any ideas why this may be or how I can track this down and resolve it?

Image attached:
View attachment 6482
It's probably bots looking for links that are usually on another software, to exploit the software. Either that, or your previous links are gone.

Go to your [Google] search console Control Panel and start checking your links as "fixed" to stop getting those.
Ok waiting for it to be validated!

Thank you for your help :D
Oh my god. You didn't have search console enabled!? Damn.

Might as well put in google analytics in there, too. You're going to need that, as well.
 

JoyFreak

Resident
I continuously have guests landing on "unknown page". Any ideas why this may be or how I can track this down and resolve it?

Image attached:
View attachment 6482
It's probably bots looking for links that are usually on another software, to exploit the software. Either that, or your previous links are gone.

Go to your [Google] search console Control Panel and start checking your links as "fixed" to stop getting those.
Ok waiting for it to be validated!

Thank you for your help :D
Oh my god. You didn't have search console enabled!? Damn.

Might as well put in google analytics in there, too. You're going to need that, as well.
Oh I did have it enabled.

I mean the broken links, they need validating after clicking "fixed". I am guessing it must go through a process first. I did see those broken links which were linking back to an old version of the forums. Which could possibly be linked to outdated links etc.

Does Bing search engine have something similar that I need to do the same process for?
 
It's probably bots looking for links that are usually on another software, to exploit the software. Either that, or your previous links are gone.

Go to your [Google] search console Control Panel and start checking your links as "fixed" to stop getting those.
Ok waiting for it to be validated!

Thank you for your help :D
Oh my god. You didn't have search console enabled!? Damn.

Might as well put in google analytics in there, too. You're going to need that, as well.
Oh I did have it enabled.

I mean the broken links, they need validating after clicking "fixed". I am guessing it must go through a process first. I did see those broken links which were linking back to an old version of the forums. Which could possibly be linked to outdated links etc.
I see, but yes old links being linked. Or vice versa. Either way, my suggestion still remains. ExodusForums is an old site, and I see the same thing, but it's likely due to old links. But my other sites show some of them, too... When I look at it, I think of "bots trying to exploit." Because I periodically check search console to tell google "I don't want these links." To do that is by fixing the links. I don't disavow them unless is malicious.
Does Bing search engine have something similar that I need to do the same process for?
Yes, but bing right now is broken.
https://twitter.com/CarlosX360/status/1084914193592209409
 

JoyFreak

Resident
Ok waiting for it to be validated!

Thank you for your help :D
Oh my god. You didn't have search console enabled!? Damn.

Might as well put in google analytics in there, too. You're going to need that, as well.
Oh I did have it enabled.

I mean the broken links, they need validating after clicking "fixed". I am guessing it must go through a process first. I did see those broken links which were linking back to an old version of the forums. Which could possibly be linked to outdated links etc.
I see, but yes old links being linked. Or vice versa. Either way, my suggestion still remains. ExodusForums is an old site, and I see the same thing, but it's likely due to old links. But my other sites show some of them, too... When I look at it, I think of "bots trying to exploit." Because I periodically check search console to tell google "I don't want these links." To do that is by fixing the links. I don't disavow them unless is malicious.
Does Bing search engine have something similar that I need to do the same process for?
Yes, but bing right now is broken.
https://twitter.com/CarlosX360/status/1084914193592209409
Where would I find these broken links on Bing so I can fix them?
 
Oh my god. You didn't have search console enabled!? Damn.

Might as well put in google analytics in there, too. You're going to need that, as well.
Oh I did have it enabled.

I mean the broken links, they need validating after clicking "fixed". I am guessing it must go through a process first. I did see those broken links which were linking back to an old version of the forums. Which could possibly be linked to outdated links etc.
I see, but yes old links being linked. Or vice versa. Either way, my suggestion still remains. ExodusForums is an old site, and I see the same thing, but it's likely due to old links. But my other sites show some of them, too... When I look at it, I think of "bots trying to exploit." Because I periodically check search console to tell google "I don't want these links." To do that is by fixing the links. I don't disavow them unless is malicious.
Does Bing search engine have something similar that I need to do the same process for?
Yes, but bing right now is broken.
https://twitter.com/CarlosX360/status/1084914193592209409
Where would I find these broken links on Bing so I can fix them?
I don't know. Every time I go to the interface, I keep asking myself the same question, but it doesn't seem to have one. (A place to "fix" links.)

It doesn't seem to be maintained enough. I just set up the websites there, and not touch it until I add a new site, or re-add the site.
 
  • Like
Reactions: JoyFreak

JoyFreak

Resident
Oh I did have it enabled.

I mean the broken links, they need validating after clicking "fixed". I am guessing it must go through a process first. I did see those broken links which were linking back to an old version of the forums. Which could possibly be linked to outdated links etc.
I see, but yes old links being linked. Or vice versa. Either way, my suggestion still remains. ExodusForums is an old site, and I see the same thing, but it's likely due to old links. But my other sites show some of them, too... When I look at it, I think of "bots trying to exploit." Because I periodically check search console to tell google "I don't want these links." To do that is by fixing the links. I don't disavow them unless is malicious.
Does Bing search engine have something similar that I need to do the same process for?
Yes, but bing right now is broken.
https://twitter.com/CarlosX360/status/1084914193592209409
Where would I find these broken links on Bing so I can fix them?
I don't know. Every time I go to the interface, I keep asking myself the same question, but it doesn't seem to have one. (A place to "fix" links.)

It doesn't seem to be maintained enough. I just set up the websites there, and not touch it until I add a new site, or re-add the site.
Ok, thanks for confirmation as I couldn't find anything on there either.
 
I see, but yes old links being linked. Or vice versa. Either way, my suggestion still remains. ExodusForums is an old site, and I see the same thing, but it's likely due to old links. But my other sites show some of them, too... When I look at it, I think of "bots trying to exploit." Because I periodically check search console to tell google "I don't want these links." To do that is by fixing the links. I don't disavow them unless is malicious.
Yes, but bing right now is broken.
https://twitter.com/CarlosX360/status/1084914193592209409
Where would I find these broken links on Bing so I can fix them?
I don't know. Every time I go to the interface, I keep asking myself the same question, but it doesn't seem to have one. (A place to "fix" links.)

It doesn't seem to be maintained enough. I just set up the websites there, and not touch it until I add a new site, or re-add the site.
Ok, thanks for confirmation as I couldn't find anything on there either.
Yup, no problem. Thing is, you'd think a multi-billion dollar corporation would have tried for feature parity with Google's own search console - since that's their primary competitor...? The fuck?
 

JoyFreak

Resident
Where would I find these broken links on Bing so I can fix them?
I don't know. Every time I go to the interface, I keep asking myself the same question, but it doesn't seem to have one. (A place to "fix" links.)

It doesn't seem to be maintained enough. I just set up the websites there, and not touch it until I add a new site, or re-add the site.
Ok, thanks for confirmation as I couldn't find anything on there either.
Yup, no problem. Thing is, you'd think a multi-billion dollar corporation would have tried for feature parity with Google's own search console - since that's their primary competitor...? The fuck?
Haha exactly. Let's hope fixing the links will resolve my unknown page error.
I'll be sure to post feedback when I see any improvement.